pcsx2/debian-unstable-upstream/patches/01_rename_binary_generated....

25 lines
788 B
Diff

Debian specific
Always uses the same executable name for the build. Easier for the install script
Index: pcsx2.snapshot-3369/pcsx2/CMakeLists.txt
===================================================================
--- pcsx2.snapshot-3369.orig/pcsx2/CMakeLists.txt
+++ pcsx2.snapshot-3369/pcsx2/CMakeLists.txt
@@ -83,7 +83,7 @@
if(CMAKE_BUILD_TYPE STREQUAL Debug)
# executable name
- set(pcsx2Name pcsx2-dbg)
+ set(pcsx2Name pcsx2)
# add defines
add_definitions(${CommonFlags} ${DebugFlags} -DPCSX2_DEVBUILD -DPCSX2_DEBUG -DWX_PRECOMP)
@@ -93,7 +93,7 @@
if(CMAKE_BUILD_TYPE STREQUAL Devel)
# executable name
- set(pcsx2Name pcsx2-dev)
+ set(pcsx2Name pcsx2)
# add defines
add_definitions(${CommonFlags} ${OptimizationFlags} -DPCSX2_DEVBUILD -DWX_PRECOMP -DNDEBUG)